Technical Support Lenovo Z50-70 problem with charging

Kema

kema78
Registered
Golden

Reputation:

Dear friends,

I have a problem with MB NM-A271 from Lenovo Z50-70, which can't charge.

There are measured values on IC BQ737 on attached picture, I think there is no problem, but please check it with me. KBC changed for the new one, BIOS and EC flashed, BQ 737 changed as well to be sure, but still not charging at all and charging LED doesn't light up. EC_SMB_CA1 and EC_SMB_DA1 checked on battery and on KBC with osciloscope. Battery changed.

Any advice what to check?

Many thanks.
 

Attachments

Hosein Asadolahi

Staff member
Registered

Reputation:

Dear friends,

I have a problem with MB NM-A271 from Lenovo Z50-70, which can't charge.

There are measured values on IC BQ737 on attached picture, I think there is no problem, but please check it with me. KBC changed for the new one, BIOS and EC flashed, BQ 737 changed as well to be sure, but still not charging at all and charging LED doesn't light up. EC_SMB_CA1 and EC_SMB_DA1 checked on battery and on KBC with osciloscope. Battery changed.

Any advice what to check?

Many thanks.
test without battery and voltcheck acok .
acok not be 0v .
 

Kema

kema78
Registered
Golden

Reputation:

same with or without battery, a few of mV
I'm pretty sure that in one of your videos here I saw ACOK should be near 0V on BQ737 series
 

Hosein Asadolahi

Staff member
Registered

Reputation:

same with or without battery, a few of mV
I'm pretty sure that in one of your videos here I saw ACOK should be near 0V on BQ737 series
acok is The right sign signal of the input voltage that the IC sends to io, and if the input voltage or other voltages required by the IC do not have the required parameters, the IC will pull down this signal.
ACOK ====> AC IS OK . SO (ac is ok = pullup) and (ac is not ok = pulldown)
In which video did you see the opposite?
 

Kema

kema78
Registered
Golden

Reputation:

Are you sure about it? In that video at the and, when MB was repaired, there was 0V on ACOK pin and battery was charging.
On MB NM-A311 or NM-A331 0V as well and battery charging.
But in my case there is some other problem which I can't detect.
 

Hosein Asadolahi

Staff member
Registered

Reputation:

Are you sure about it? In that video at the and, when MB was repaired, there was 0V on ACOK pin and battery was charging.
On MB NM-A311 or NM-A331 0V as well and battery charging.
But in my case there is some other problem which I can't detect.
sorry , You are right .
BQ707, BQ727 , BQ737 need ACOK LOW
BQ705, BQ725 , BQ735 need ACOK HIGH

so its ok if acok is low .
do you ohm check pr201 and pr202 ?
 

Hosein Asadolahi

Staff member
Registered

Reputation:

Nobody would help?
you do all of this :
change battery .
change io with new one .
change bq ic with new one .
progrom bios and ec with ok file .

so maybe one of the above item have problem or incorrect placeded .
or other components aronde of bq ic or io have problem .
or connection between of battery to bq or bq to io or adaptor to bq have disconnected .
or pq303 have problem
or other mosfet of driving circet of pq303 gate pin have problem

i havent any idea except this items
 
Top